Affichage carte simple - Problème

Discussions sur l'API CUB
Mendez
Messages : 5
Enregistré le : 27 janvier 2017, 14:24

Affichage carte simple - Problème

Message par Mendez »

Bonjour,
Je viens de découvrir les API de Bordeaux, et j'ai trouvé cela relativement intéressant. Cependant lorsque j'essaie de les exploiter, ça coince..
En effet j'ai demandé une clé, que j'ai obtenu, et par la suite j'ai essayé de faire le premier tutoriel pour afficher une carte Google, mais rien ne se passe : j'ai bien le "© Bordeaux Métropole" en bas à gauche, mais aucune image ne charge. J'ai essayé alors d'autres tutoriels pour voir si ce n'était pas un problème de l'API, mais j'obtiens le même problème.
Pour voir si cela venait de moi, j'ai copié le code source d'un exemple qui lui fonctionne parfaitement, j'ai remplacé juste le lien de src avec ma clé et en rajoutant "http:", mais idem cela ne fonctionne pas.

Pour finir, je me suis posé la question si le problème ne venait pas du fait que mon fichier était lancé en local. J'ai donc hébergé le code, mais toujours rien.

Si vous avez une idée qui pourrait résoudre mon problème, je suis preneur.
Merci d'avance.
Nicolas Bellengé

Re: Affichage carte simple - Problème

Message par Nicolas Bellengé »

Bonjour,

pourriez vous nous envoyer par message privé l'adresse de votre site de test hébergé afin de jeter un oeil à votre code source ?

QU'entendez vous par "j'ai remplacé juste le lien de src avec ma clé et en rajoutant "http:" " ?
Mendez
Messages : 5
Enregistré le : 27 janvier 2017, 14:24

Re: Affichage carte simple - Problème

Message par Mendez »

Pour le site je vous l'enverrai ce soir car malheureusement j'ai créé une adresse mail spécifique pour l'hébergeur dont je ne me souviens plus
(n'étant pas chez moi actuellement).

J'ai ajouté "http:" devant scr car sinon le lien est : src="//data.bordeaux-metropole.fr/API/cub.xjs?key=Ma clé"
Et à ce moment là il ne trouve pas l'API.

Avec src="http://data.bordeaux-metropole.fr/API/cub.xjs?key=Ma clé" Il me le trouve.
Nicolas Bellengé

Re: Affichage carte simple - Problème

Message par Nicolas Bellengé »

Vous dites avoir utilisé l'exemple de carte simple pour vos essais.

Avez vous modifié votre clé dans l'url du script javascript ET dans le code javascript quelques lignes plus bas ( new CUB.Layer.Static ) ?
Modifié en dernier par Nicolas Bellengé le 06 février 2017, 11:53, modifié 2 fois.
Mendez
Messages : 5
Enregistré le : 27 janvier 2017, 14:24

Re: Affichage carte simple - Problème

Message par Mendez »

Oui j'ai bien modifié tous les URL où l'on demandait une clé.
C'est ce que je trouve bizarre : J'ai exactement le même code source (j'ai modifié les clé par la mienne).
Sébastien Cart-Lamy
Équipe OpenData
Équipe OpenData
Messages : 309
Enregistré le : 23 juin 2011, 16:16

Re: Affichage carte simple - Problème

Message par Sébastien Cart-Lamy »

Bonjour,
Le premier problème vient du fait que vous exécutez le code en local avec du adresse du type "file://"

Dans tous les cas, il faut que l'URL de votre page comment par http:// ou https:// (et les URL internes au code doivent commencer par le même protocole pour éviter les blocages du navigateur).

Est-ce le cas ?
Mendez
Messages : 5
Enregistré le : 27 janvier 2017, 14:24

Re: Affichage carte simple - Problème

Message par Mendez »

Oui ça l'est. C'est justement ce que j'ai modifié dans le code source pour avoir un lien valide.
Sébastien Cart-Lamy
Équipe OpenData
Équipe OpenData
Messages : 309
Enregistré le : 23 juin 2011, 16:16

Re: Affichage carte simple - Problème

Message par Sébastien Cart-Lamy »

Qu'indique le debugger / console sur les requêtes faites au serveur ?
Mendez
Messages : 5
Enregistré le : 27 janvier 2017, 14:24

Re: Affichage carte simple - Problème

Message par Mendez »

Le débogueur m'indiquait que j'avais des erreurs dans mon code HTML.
En effet, il manquait la ligne "<meta charset="utf-8" />" ce qui a résolu tout mes problèmes ! Merci :)
i7d1hC4MjnhLIsSjTW
Messages : 9
Enregistré le : 21 février 2017, 10:18

Re: Affichage carte simple - Problème

Message par i7d1hC4MjnhLIsSjTW »

Dans tous les cas, il faut que l'URL de votre page comment par http:// ou https:// (et les URL internes au code doivent commencer par le même protocole pour éviter les blocages du navigateur).
J'ai eu le même problème. Quelle est la raison qui empêche de créer un page locale avec votre API/scripts ? Un simple adressage en http ou https dans un cub.xjs ne solutionnerai-t'il pas le problème ?

Code : Tout sélectionner

B.ImgPath = "//data.bordeaux-metropole.fr/api/images/"
;
Répondre