Problème de certificat SSL

Discussions autour des WebServices WMS / WFS / WPS de la CUB
Répondre
Diplay
Messages : 23
Enregistré le : 21 mars 2022, 23:21

Problème de certificat SSL

Message par Diplay »

Bonjour,

Tout d’abord, bonne année à vous, tous mes meilleurs vœux.

Je souhaite vous signaler un problème concernant votre certificat SSL lorsqu’on appelle vos WebServices, et ce, depuis la fin de la semaine dernière. Pourriez-vous régler ce problème au plus vite svp ?

Merci d’avance !
Bonne journée,
HU Jacques
Sébastien Cart-Lamy
Équipe OpenData
Équipe OpenData
Messages : 352
Enregistré le : 23 juin 2011, 16:16

Re: Problème de certificat SSL

Message par Sébastien Cart-Lamy »

Bonjour Jacques,
Peux-tu être très précis sur le "problème" ?
Diplay
Messages : 23
Enregistré le : 21 mars 2022, 23:21

Re: Problème de certificat SSL

Message par Diplay »

Quand j’appelle un service tel que `sv_vehic_p`, une erreur m’indiquant l’impossibilité de vérifier le certificat SSL apparaît. J’avoue ne pas pouvoir fournir plus de détails que cela. L’erreur survient quand je requête en `https`, mais pas en `http`.

Cdlt,
HU Jacques
Sébastien Cart-Lamy
Équipe OpenData
Équipe OpenData
Messages : 352
Enregistré le : 23 juin 2011, 16:16

Re: Problème de certificat SSL

Message par Sébastien Cart-Lamy »

Cela peut sembler évident pour toi, mais ça ne l'est pas pour nous ;)
Nous avons un certain nombre de services et actuellement il n'y a pas de panne avérée.

Aussi, peux-tu préciser :
  • L'URL complète que tu appelles
  • Le client que tu utilises
  • Le résultat exact (ou un capture d'écran)
Diplay
Messages : 23
Enregistré le : 21 mars 2022, 23:21

Re: Problème de certificat SSL

Message par Diplay »

Ça n’est pas non plus évident pour moi, pour le coup ^^’

Je vais essayer du mieux que je peux. Le problème dont je parle, à l’air de se produire peu importe le service que j’appelle.
Prenons donc l’exemple de la couche `sv_vehic_p`. Je l’appelle avec l’outil Postman, avec l’URL suivante : `https://data.bordeaux-metropole.fr/geojson?key=[api_key]&typename=sv_vehic_p`. Le serveur en lui-même ne renvoie pas d’erreur, puisque j’ai un code 200 avec les données qui vont avec. Cependant, j’ai une erreur d’affichée, avec les détails qui suivent :
Image
Ce cas vaut dont pour l’appel de vos services, depuis Postman, et dans l’URL, quand je remplace `https://` par `http://`, je n’ai pas ce problème puisque le certificat n’est pas vérifié.

Là où cela devient plus bloquant, c’est depuis du code Kotlin. Dans le cas où j’appelle via `OkHttpClient`, je suis renvoyé directement dans l’erreur (la suivante : `javax.net.ssl.SSLHandshakeException: java.security.cert.CertPathValidatorException: Trust anchor for certification path not found.`) sans recevoir de réponse de la part du serveur. Alors, cela peut-être corrigé de façon temporaire, en utilisant `http` et non `https`.

Merci d’avance,
HU Jacques
Sébastien Cart-Lamy
Équipe OpenData
Équipe OpenData
Messages : 352
Enregistré le : 23 juin 2011, 16:16

Re: Problème de certificat SSL

Message par Sébastien Cart-Lamy »

Je reproduis bien l'avertissement

Cela a été transmis aux équipes en charge des certificats en interne.
Diplay
Messages : 23
Enregistré le : 21 mars 2022, 23:21

Re: Problème de certificat SSL

Message par Diplay »

Merci à toi.

HU Jacques
Sébastien Cart-Lamy
Équipe OpenData
Équipe OpenData
Messages : 352
Enregistré le : 23 juin 2011, 16:16

Re: Problème de certificat SSL

Message par Sébastien Cart-Lamy »

Le problème est désormais résolu
Diplay
Messages : 23
Enregistré le : 21 mars 2022, 23:21

Re: Problème de certificat SSL

Message par Diplay »

Je viens effectivement de voir ça. Merci beaucoup de ton aide.

Cordialement,
HU Jacques
Répondre